xiaoming728

xiaoming728

Nuxt.js 部署

17
2024-07-11
Nuxt.js 部署

安装node

CentOS7安装nodejs18和yarn

从nodejs18开始就不支持Centos7了,这是因为centos7的gilbc版本比较低,因此需要安装非官方构建的版本

如果npm安装的包依赖于glibc,那得改用docker或者换操作系统了。

到非官方发布版本网站下载压缩包node-v18.19.0-linux-x64-glibc-217.tar.gz

https://unofficial-builds.nodejs.org/download/release/v18.19.0/

上传文件到服务器,并解压到文件夹/opt

mv node-v18.19.0-linux-x64-glibc-217 node-v18

进入/etc/profile.d文件夹

cd /etc/profile.d

创建环境变量文件,然后保存

vi nodejs.sh
export NODE_HOME=/opt/node-v18
export PATH=.:$NODE_HOME/bin:$PATH

重新加载环境变量

source /etc/profile

安装pm2

npm install pm2@latest -g

安装git

sudo yum install git

拉代码

git clone https://gitee.com/xxx.git

切分支

git branch -r
git checkout main

更新代码

git pull origin main

部署在代码目录下

npm install
npm run build
pm2 start ecosystem.config.cjs

如果启动失败先把pm2给kill掉

ps -ef|grep pm2

再重新启动

pm2 start ecosystem.config.cjs